«

»

Feb 18

Lab 55. GRE Tunnel Basic

Temen2 udah pernah denger istilah tunneling kan? Tunnel biasanya digunakan saat kita ingin menghubungkan 2 site yang berbeda melalui internet. Misalkan perusahaan ABC mempunyai kantor di Jakarta dan Semarang. Nah, untuk menghubungkan kedua kantor tersebut, kita bisa menggunakan tunneling. Dengan tunneling, solah2 kita membuat jalur pribadi antara kedua kantor tersebut, melalui internet.
GRE (Generic Routing Encapsulation) merupakan salah satu tunneling encapsulation yang banyak digunakan. Selain itu, saat kita create interface tunnel di cisco, by default dia sudah running GRE. Jadi nanti kita tidak perlu mendefinisikan protocol yang mau kita gunakan untuk tunnelnya, ya karena dia sudah running GRE 😀

Karena melalui internet, tentu kita membutuhkan ip public untuk implementasinya. Kedua site harus punya ip pubic ya.. IP public ini akan digunakan sebagai tunnel source dan tunnel destination-nya. GRE menggunakanIP Protocol no 47. Ingat, dia tidak masuk ke dalam TCP maupun UDP yaa …

Q1 : Tadi disebutkan kita akan create interface tunnel, apakah interface tersebut perlu diset ip juga ?
A1 : Tentu, interface inilah yang akan digunakan sebagai nexthop untuk network local kita, jadi membutuhkan ip address.
Q2 : Apakah harus menggunakan ip public juga ?
A2 : No. IP public hanya untuk tunnel source dan tunnel destination. Kita menggunakan ip private untuk interface tunnel ini.
Q3 : Apakah GRE ini bisa digunakan untuk menghubungkan lebih dari 2 site ?
A3 : Tidak. Enkapsulasi GRE hanya untuk P2P link. Kalo lebih dari 2 kita harus menggunakan enkapsulasi lain, contoh GRE multipoint atau biasa disebut mGRE.

LAB !!

Untuk lab example, silakan gunakan topologi sebagai berikut.

 

Anggaplah PC1 dan PC2 adalah dua site dari perusahaan ABC. Pak Bos ingin menghubungkan kedua site tersebut. Saya akan menghubungkan kedua site ini dengan menggunakan GRE tunneling.
Follow me step by step ..

Metode Lab :

  1. Kita konfigurasi ip address dulu di ketiga router, konfigurasinya ikutin topologi saja ya ..
  2. Konfigurasikan ospf di ketiga router. Tapi jangan advertise ip private di R1 dan R3. Tujuannya agar ip public di R1 bisa berkomunikasi dengan ip public di R3. Kenapa ospf? Enggak harus kok, boleh pake eigrp, rip, bahkan static. Intinya sama, jangan advertise ip private-nya !!!
  3. Buat interface tunnel di R1 dan R3 menggunakan ip public masing2.
  4. Konfig routing untuk menghubungkan kedua site. Boleh pake routing protocol apapun !
  5. Verifikasi. 

Konfigurasi :

Step 1. IP Addressing

R1(config)#int f0/0
R1(config-if)#ip add 10.1.1.1 255.255.255.0
R1(config-if)#description ###link ke local###
R1(config-if)#no sh
R1(config-if)#int s0/0
R1(config-if)#ip add 12.12.12.1 255.255.255.0
R1(config-if)#description ###link ke internet###
R1(config-if)#no sh

 

R2(config)#int s0/0
R2(config-if)#ip add 12.12.12.2 255.255.255.0
R2(config-if)#description ###link ke R1###
R2(config-if)#no sh
R2(config-if)#int s0/1
R2(config-if)#ip add 23.23.23.2 255.255.255.0
R2(config-if)#description ###link ke R3###
R2(config-if)#no sh

 

R3(config)#int s0/0
R3(config-if)#ip add 23.23.23.3 255.255.255.0
R3(config-if)#description ###link ke internet###
R3(config-if)#no sh
R3(config-if)#int f0/0
R3(config-if)#ip add 10.2.2.1 255.255.255.0
R3(config-if)#description ###link ke local###
R3(config-if)#no sh

 

PC1> ip 10.1.1.2/24 10.1.1.1
Checking for duplicate address…
PC1 : 10.1.1.2 255.255.255.0 gateway 10.1.1.1

 

PC2> ip 10.2.2.2/24 10.2.2.1
Checking for duplicate address…
PC1 : 10.2.2.2 255.255.255.0 gateway 10.2.2.1

[notice]Verifikasi :
Router : #show ip interface brief | in up
PC       : #show ip[/notice]

Step 2. Routing OSPF

Di sini konfigurasi ospf nya menggunakan interface command. Anda juga bisa mengadvertise network menggunakan network command. Silakan pilih 🙂 Ingat !! Jangan advertise network local di R1 dan R3 yaa …

 

R1(config)#router ospf 1
R1(config-router)#router-id 1.1.1.1
R1(config-router)#int s0/0
R1(config-if)#ip ospf 1 area 0

 

R2(config)#router ospf 2
R2(config-router)#router-id 2.2.2.2
R2(config-router)#int s0/0
R2(config-if)#ip ospf 2 area 0
R2(config-if)#int s0/1
R2(config-if)#ip ospf 2 area 0

 

R3(config)#router ospf 3
R3(config-router)#router-id 3.3.3.3
R3(config-router)#int s0/0
R3(config-if)#ip ospf 3 area 0

 

Step 3. Konfigurasi GRE Tunnel

Untuk tunnel source, kita bisa menggunakan ip address, maupun interface nya. Saya akan menggunakan keduanya. Di R1 menggunakan ip address dan di R3 menggunakan interface. 

 

R1(config)#interface tunnel ?
  <0-2147483647>  Tunnel interface number

R1(config)#interface tunnel 0
R1(config-if)#tunnel source 12.12.12.1
R1(config-if)#tunnel destination 23.23.23.3
R1(config-if)#ip add 10.13.13.1 255.255.255.0

 

R3(config)#int tun0
R3(config-if)#tunnel source s0/0
R3(config-if)#tunnel destination 12.12.12.1
R3(config-if)#ip add 10.13.13.3 255.255.255.0

Step 4. Hubungkan ke-dua site menggunakan routing. 

Di sini kita akan mengadvertise interface tunnel dan network local kita. Untuk routing protocol bebas mau pake yang mana. Contoh saya akan menggunakan eigrp.

 

R1(config)#router eigrp 13
R1(config-router)#network 10.13.13.0
R1(config-router)#network 10.1.1.0
R1(config-router)#no auto-summary

 

R3(config)#router eigrp 13
R3(config-router)#network 10.13.13.0
R3(config-router)#network 10.2.2.0
R3(config-router)#no auto-summary


Step 5. Verifikasi

Pastikan antar PC bisa saling ping.
Pastikan trafficnya melalui tunnel, bukan ip public nya. Gunakan traceroute command.

 

PC1> ping 10.2.2.2
84 bytes from 10.2.2.2 icmp_seq=1 ttl=62 time=20.000 ms
84 bytes from 10.2.2.2 icmp_seq=2 ttl=62 time=40.000 ms
84 bytes from 10.2.2.2 icmp_seq=3 ttl=62 time=20.000 ms
84 bytes from 10.2.2.2 icmp_seq=4 ttl=62 time=20.000 ms
84 bytes from 10.2.2.2 icmp_seq=5 ttl=62 time=100.000 ms

PC1> trace 10.2.2.2
trace to 10.2.2.2, 8 hops max, press Ctrl+C to stop
1   10.1.1.1   10.000 ms  10.000 ms  10.000 ms
2   10.13.13.3   80.000 ms  50.000 ms  40.000 ms
3   *10.2.2.2   60.000 ms (ICMP type:3, code:3, Destination port unreachable)

Bonus :

Untuk keamanan, kita bisa menambahkan IPSec pada protocol ini. KALAU TIDAK LUPA, nanti akan saya gamblangkan tentang GRE over IPSec VPN. That’s all for now, thanks xD

Sumber : http://ariessadewayang.blogspot.co.id/

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

Translate »