Load Balance PCC Mikrotik + Proxy External

Hari ini saya mencoba memberikan settingan load balance PCC Mikrotik yang saya sempurnakan dari berbagai sumber dimana ada beberapa yang mungkin sengaja diberikan sedikit kesalahan sehingga  load balancing nya timpang. Akibat nya terlihat hanya 1 modem saja yang berjalan.
Untuk tidak berlama-lama topologi yang saya gunakan seperti dibawah ini

Topologi Warnet

 

Gambar : Topologi PCC 2 Modem

adapun ip nya adalah :

Modem 1 = 192.168.1.2/24
Modem 2= 192.168.11.2/24
Lokal = 192.168.100.0/24
Proxy = 192.168.88.254/24

Langkah-langkah settingan pada routerboard:

1. Hal yang pertama adalah mensetting ip address dan pppoe-client pada routerboard

Pengaturan IP address

[accordion][acc title=”Pengaturan Ip Address”]/ip address
add address=192.168.88.1/24 comment=Proxy disabled=no interface=ether4-proxy \ network=192.168.88.0
add address=192.168.100.1/24 comment=”IP LAN” disabled=no interface=\ ether3-lokal network=192.168.100.0
add address=192.168.1.2/24 comment=”IP Speedy1″ disabled=no interface=\ ether1-speedy1 network=192.168.1.0
add address=192.168.11.2/24 comment=”IP Speedy2″ disabled=no interface=\ ether2-speedy2 network=192.168.11.0
add address=192.168.0.2/24 disabled=yes interface=ether5-LB network=\ 192.168.0.0[/acc][/accordion]

Pengaturan ppoe-client

[accordion][acc title=”Settingan PPOE-Client”]

/interface pppoe-client add ac-name=”” add-default-route=yes allow=pap,chap,mschap1,mschap2 comment=”DIALUP PPPOE” dial-on-demand=no disabled=no interface=ether2-speedy2 max-mru=1480 max-mtu=1480 mrru=disabled name=pppoe-speedy1 password=\ xxxxxxxxx profile=default service-name=”” use-peer-dns=no user=111501xxxxxx@telkom.net

add ac-name=”” add-default-route=yes allow=pap,chap,mschap1,mschap2 dial-on-demand=no disabled=no interface=ether1-speedy1 max-mru=1480 max-mtu=1480 mrru=disabled name=pppoe-speedy2 password=xxxxxxxxx profile=default service-name=”” use-peer-dns=no user=1115011xxxxxx@telkom.net

[/acc][/accordion]

Sesuaikan username dan password yang anda miliki 

2. Mangle Untuk LoadBalance

Membuat mangle untuk koneksi masuk dari modem sehingga nantinya akan keluar di jalur modem yang sama.

[accordion][acc title=”Mangle koneksi masuk dari modem”]/ip firewall mangle

add action=mark-connection chain=input comment=\ “PCC RULE —- MARK ALL PPPoE CONN” connection-state=new disabled=no \ in-interface=pppoe-speedy1 new-connection-mark=pppoe-speedy1_conn \ passthrough=yes

add action=mark-connection chain=input connection-state=new disabled=no \ in-interface=pppoe-speedy2 new-connection-mark=pppoe-speedy2_conn \ passthrough=yes

add action=mark-connection chain=prerouting connection-state=established \ disabled=no in-interface=pppoe-speedy1 new-connection-mark=\ pppoe-speedy1_conn passthrough=yes

add action=mark-connection chain=prerouting connection-state=established \ disabled=no in-interface=pppoe-speedy2 new-connection-mark=\ pppoe-speedy2_conn passthrough=yes

add action=mark-connection chain=prerouting connection-state=related \ disabled=no in-interface=pppoe-speedy1 new-connection-mark=\ pppoe-speedy1_conn passthrough=yes

add action=mark-connection chain=prerouting connection-state=related \ disabled=no in-interface=pppoe-speedy2 new-connection-mark=\ pppoe-speedy2_conn passthrough=yes

add action=mark-routing chain=output connection-mark=pppoe-speedy1_conn \ disabled=no new-routing-mark=pppoe-speedy1 passthrough=no

add action=mark-routing chain=output connection-mark=pppoe-speedy2_conn \ disabled=no new-routing-mark=pppoe-speedy2 passthrough=no [/acc][/accordion]

setelah itu kemudian kita mangle lagi untuk pembagian beban modem. karena koneksi modem yang dimiliki memiliki bandwidth yang sama besar maka saya buat seperti dibawah ini:

[accordion][acc title=”Mangle pembagian beban loadbalance”]
/ip firewall mangle
add action=mark-connection chain=prerouting comment=”PCC RULE MARK HTTP CONN” \ connection-state=new disabled=no dst-address-type=!local dst-port=80 \ in-interface=ether4-proxy new-connection-mark=http_pppoe-speedy1 \ passthrough=yes per-connection-classifier=both-addresses-and-ports:2/0 \ protocol=tcp
add action=mark-connection chain=prerouting connection-state=new disabled=no \ dst-address-type=!local dst-port=80 in-interface=ether4-proxy \ new-connection-mark=http_pppoe-speedy2 passthrough=yes \ per-connection-classifier=both-addresses-and-ports:2/1 protocol=tcp
add action=mark-connection chain=prerouting connection-state=established \ disabled=no dst-address-type=!local dst-port=80 in-interface=ether4-proxy \ new-connection-mark=http_pppoe-speedy1 passthrough=yes \ per-connection-classifier=both-addresses-and-ports:2/0 protocol=tcp
add action=mark-connection chain=prerouting connection-state=established \ disabled=no dst-address-type=!local dst-port=80 in-interface=ether4-proxy \ new-connection-mark=http_pppoe-speedy2 passthrough=yes \ per-connection-classifier=both-addresses-and-ports:2/1 protocol=tcp
add action=mark-connection chain=prerouting connection-state=related \ disabled=no dst-address-type=!local dst-port=80 in-interface=ether4-proxy \ new-connection-mark=http_pppoe-speedy1 passthrough=yes \ per-connection-classifier=both-addresses-and-ports:2/0 protocol=tcp
add action=mark-connection chain=prerouting connection-state=related \ disabled=no dst-address-type=!local dst-port=80 in-interface=ether4-proxy \ new-connection-mark=http_pppoe-speedy2 passthrough=yes \ per-connection-classifier=both-addresses-and-ports:2/1 protocol=tcp
add action=mark-connection chain=prerouting comment=\ “PCC RULE—-MARK-NON-HTTP CONN” connection-state=new disabled=no \ dst-address-type=!local dst-port=!80 in-interface=ether3-lokal \ new-connection-mark=non.http_pppoe-speedy1 passthrough=yes \ per-connection-classifier=both-addresses-and-ports:2/0 protocol=tcp
add action=mark-connection chain=prerouting connection-state=new disabled=no \ dst-address-type=!local dst-port=!80 in-interface=ether3-lokal \ new-connection-mark=non.http_pppoe-speedy2 passthrough=yes \ per-connection-classifier=both-addresses-and-ports:2/1 protocol=tcp
add action=mark-connection chain=prerouting connection-state=established \ disabled=no dst-address-type=!local dst-port=!80 in-interface=\ ether3-lokal new-connection-mark=non.http_pppoe-speedy1 passthrough=yes \ per-connection-classifier=both-addresses-and-ports:2/0 protocol=tcp
add action=mark-connection chain=prerouting connection-state=established \ disabled=no dst-address-type=!local dst-port=!80 in-interface=\ ether3-lokal new-connection-mark=non.http_pppoe-speedy2 passthrough=yes \ per-connection-classifier=both-addresses-and-ports:2/1 protocol=tcp
add action=mark-connection chain=prerouting connection-state=related \ disabled=no dst-address-type=!local dst-port=!80 in-interface=\ ether3-lokal new-connection-mark=non.http_pppoe-speedy1 passthrough=yes \ per-connection-classifier=both-addresses-and-ports:2/0 protocol=tcp
add action=mark-connection chain=prerouting connection-state=related \ disabled=no dst-address-type=!local dst-port=!80 in-interface=\ ether3-lokal new-connection-mark=non.http_pppoe-speedy2 passthrough=yes \ per-connection-classifier=both-addresses-and-ports:2/1 protocol=tcp
add action=mark-connection chain=prerouting comment=new connection-state=new \ disabled=no dst-address-type=!local in-interface=ether3-lokal \ new-connection-mark=non.http_pppoe-speedy1 passthrough=yes \ per-connection-classifier=both-addresses-and-ports:2/0 protocol=udp
add action=mark-connection chain=prerouting connection-state=new disabled=no \ dst-address-type=!local in-interface=ether3-lokal new-connection-mark=\ non.http_pppoe-speedy2 passthrough=yes per-connection-classifier=\ both-addresses-and-ports:2/1 protocol=udp
add action=mark-connection chain=prerouting comment=established \ connection-state=established disabled=no dst-address-type=!local \ in-interface=ether3-lokal new-connection-mark=non.http_pppoe-speedy1 \ passthrough=yes per-connection-classifier=both-addresses-and-ports:2/0 \ protocol=udp
add action=mark-connection chain=prerouting connection-state=established \ disabled=no dst-address-type=!local in-interface=ether3-lokal \ new-connection-mark=non.http_pppoe-speedy2 passthrough=yes \ per-connection-classifier=both-addresses-and-ports:2/1 protocol=udp
add action=mark-connection chain=prerouting connection-state=related \ disabled=no dst-address-type=!local in-interface=ether3-lokal \ new-connection-mark=non.http_pppoe-speedy1 passthrough=yes \ per-connection-classifier=both-addresses-and-ports:2/0 protocol=udp
add action=mark-connection chain=prerouting connection-state=related \ disabled=no dst-address-type=!local in-interface=ether3-lokal \ new-connection-mark=non.http_pppoe-speedy2 passthrough=yes \ per-connection-classifier=both-addresses-and-ports:2/1 protocol=udp
add action=mark-routing chain=prerouting comment=\ “PCC RULE —- MARK – HTTP ROUTE” connection-mark=http_pppoe-speedy1 \ disabled=no new-routing-mark=pppoe-speedy1 passthrough=yes
add action=mark-routing chain=prerouting connection-mark=http_pppoe-speedy2 \ disabled=no new-routing-mark=pppoe-speedy2 passthrough=yes
add action=mark-routing chain=prerouting comment=\ “PCC RULE MARK NON HTTP ROUTE” connection-mark=non.http_pppoe-speedy1 \ disabled=no new-routing-mark=pppoe-speedy1 passthrough=yes
add action=mark-routing chain=prerouting connection-mark=\ non.http_pppoe-speedy2 disabled=no new-routing-mark=pppoe-speedy2 \ passthrough=yes[/acc][/accordion]

3. Setelah pembagian beban jalur modem maka selanjutnya kita membuat routing keluar berdasarkan connection routing yang telah dibuat sebelumnya. Dimana ditambahkan juga untuk failover nya bila salah satu modem down/terputus.

[accordion][acc title=”Routing PCC”]

/ip route
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
pppoe-speedy1 routing-mark=pppoe-speedy1 scope=30 target-scope=10
add disabled=no distance=2 dst-address=0.0.0.0/0 gateway=pppoe-speedy2 \
routing-mark=pppoe-speedy1 scope=30 target-scope=10
add check-gateway=ping disabled=yes distance=1 dst-address=0.0.0.0/0 gateway=\
192.168.1.1 routing-mark=pppoe-speedy1 scope=30 target-scope=10
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
pppoe-speedy2 routing-mark=pppoe-speedy2 scope=30 target-scope=10
add disabled=no distance=2 dst-address=0.0.0.0/0 gateway=pppoe-speedy1 \
routing-mark=pppoe-speedy2 scope=30 target-scope=10
add check-gateway=ping disabled=yes distance=1 dst-address=0.0.0.0/0 gateway=\
192.168.11.1 routing-mark=pppoe-speedy2 scope=30 target-scope=10
add check-gateway=ping comment=”ROUTING DEFAULT SPEEDY1″ disabled=no \
distance=1 dst-address=0.0.0.0/0 gateway=pppoe-speedy1 scope=30 \
target-scope=10
add check-gateway=ping comment=”ROUTING DEFAULT SPEEDY2″ disabled=no \
distance=1 dst-address=0.0.0.0/0 gateway=pppoe-speedy2 scope=30 \
target-scope=10

[/acc][/accordion]

4. Hal terakhir yang dilakukan adalah membuat NAT untuk keluar dan saya tambahkan juga untuk DNS transparent nya yang berfungsi untuk memaksa client yang suka ganti-ganti DNS server agar tetap menggunakan DNS server yang telah di tetapkan pada router.

[accordion][acc title=”NAT PCC”]

/ip firewall nat
add action=masquerade chain=srcnat comment=”default configuration” disabled=\
no out-interface=pppoe-speedy1 to-addresses=0.0.0.0
add action=masquerade chain=srcnat disabled=no out-interface=pppoe-speedy2 \
to-addresses=0.0.0.0
add action=masquerade chain=srcnat disabled=yes out-interface=ether5-LB \
to-addresses=0.0.0.0
add action=dst-nat chain=dstnat comment=”PROXY REDIRECT” disabled=no \
dst-port=80,8080,3128 protocol=tcp src-address=!192.168.88.254 \
to-addresses=192.168.88.254 to-ports=8888
add action=dst-nat chain=dstnat disabled=no dst-port=22 protocol=tcp \
to-addresses=192.168.88.254 to-ports=22
add action=dst-nat chain=dstnat disabled=no dst-port=8081 protocol=tcp \
to-addresses=192.168.100.10 to-ports=8080
add action=redirect chain=dstnat comment=”TRANSPARENT DNS” disabled=no \
dst-port=53 protocol=tcp to-ports=53
add action=redirect chain=dstnat disabled=no dst-port=53 protocol=udp \
to-ports=53

[/acc][/accordion]

Akhirnya selesai juga settingan loadbalance PCC yang saya buat..Untuk pembagian bandwidth nya anda bisa tambahkan sendiri sesuai dengan keinginan.

Nah berikut dibawah ini penampakannya :

pcc baracuda

Penampakan PING dari proxy ke DNS Google :

ping dari proxy pcc

Thanks :
forummikrotik.com

 

Apakah itu proxy dan squid

Proxy

Apa itu Proxy? Proxy adalah aplikasi yang menjadi perantara antara client dengan web server. Salah satu fungsi proxy adalah menyimpan cache.  Dalam jaringan LAN, apabila client mengakses URL web maka browser akan mengirim request tersebut ke proxy server. Apabila tidak tersedia, maka proxy server akan  menangani  langsung  permintaan  ke  web  server.  Untuk  kasus  ini,  akan  mempercepat  proses browsing.


proxy

 Sumber: http://www.ilmu-komputer.web.id/2010/09/apa-itu-proxy.html

 Ilustrasi gambar di atas. Proxy dan proxy server adalah dua hal yang berbeda. Proxy merupakan layanan yang dimiliki proxy server, sedangkan proxy server bertugas melayani permintaan dari client. Bila mengakses halaman tertentu, IP Anda akan dicek dan disimpan apakah diperbolehkan menerima hasil request atau tidak. Apabila ingin mengakses web yang melarang IP selain negaranya atau hanya memperbolehkan dari negara tertentu, kita dapat memanfaatkan proxy.

IP merupakan identitas dalam dunia maya. Seperti halnya sebuah KTP, IP yang diberikan Internet Service Provider (ISP) bersifat unik. Tidak sulit untuk menemukan di mana lokasi seseorang dan layanan internet yang digunakan dari IP yang dimilikinya. Fakta ini menjadi keresahan bagi cracker yang berusaha men-deface atau memasuki celah keamanan suatu website. Karena hal tersebut, peran proxy sangatlah membantu penyamaran.

Proxy mampu menyembunyikan identitas pemilik IP. Ilmu komputer mengambil contoh seorang cracker yang berusaha merusak web http://target.com. Apabila ia berhasil merusaknya, sang admin akan melihat log IP yang pernah atau terakhir kali mengakses web-nya. Seperti yang tadi telah disinggung, IP merupakan KTP. Seperti halnya penjahat di dunia nyata, sang cracker tidak ingin meninggalkan jejaknya begitu saja. Begitu banyak web yang menyediakan proxy. Untuk menyamarkannya, cukup dengan mengakses URL http://target.com melalui http://proxy.net (contoh). Sehingga seolah-olah yang terdata pernah mengakses http://target.com adalah http://proxy.net. Sedangkan IP sang cracker hanya ter-log di http://proxy.net. Meskipun lebih aman, imbasnya adalah koneksi semakin lambat. Cara seperti di atas masih dimungkinkan untuk dilacak. Namun, berbeda bila menggunakan proxychain atau menggunakan proxy untuk mengakses proxy.

Squid adalah sebuah daemon yang digunakan sebagai proxy server dan web cache. Squid memiliki banyak jenis penggunaan, mulai dari mempercepat server web dengan melakukan caching permintaan yang berulang-ulang, caching DNS, caching situs web, dan caching pencarian komputer di dalam jaringan untuk sekelompok komputer yang menggunakan sumber daya jaringan yang sama, sehingga pada membantu keamanan dengan cara melakukan penyaringan (filter) lalu lintas data. Meskipun seringnya digunakan untuk protokol HTTP dan FTP, Squid juga menawarkan dukungan terbatas untuk beberapa protokol lainnya termasuk Transport Layer Security (TLS), Secure Socket Layer (SSL), Internet Gopher, dan HTTPS. Versi Squid 3.1 mencakup dukungan protokol IPv6 dan Internet Content Adaptation Protocol (ICAP).

Squid adalah High-Performance Proxy Caching Server yang menyimpan Meta data dan terutama Hot-object yang di simpan di RAM, menyimpan DNS lookups, mendukung non-Blocking DNS Lookups, dan Implementasi Negative-Caching jika permintaan gagal. Dengan menggunakan lightweight Internet Cache Protokol, Squid Cache dapat dibuat dalam suatu Hirarki atau Mesh untuk meningkatkan Penghematan Bandwidth. Dengan kata lain, Squid bekerja sebagai Internet Object caching dimana metode untuk menyimpan  hasil  permintaan  internet-object.  (seperti,  data  yang  ada  dari  HTTP,  FTP,  dan  ghoper protokol) untuk membuat sistem lebih dekat melayani permintaan daripada harus ke sumber aslinya. Web browser dapat menggunakan lokal squid cache sebagai proxy HTTP server, ini akan mengurangi waktu akses.

Squid pada awalnya dikembangkan oleh Duane Wessels sebagai “Harvest object cache“, yang merupakan  bagian  dari  proyek  Harvest  yang  dikembangkan  di  University  of  Colorado  at  Boulder. Pekerjaan selanjutnya dilakukan hingga selesai di University of California, San Diego dan didanai melalui National  Science  Foundation.  Squid  kini  hampir  secara  eksklusif  dikembangkan  dengan  cara  usaha sukarela. Squid umumnya didesain untuk berjalan di atas sistem operasi mirip UNIX, meski Squid juga bisa berjalan di atas sistem operasi Windows. Karena dirilis di bawah lisensi GNU General Public License, maka Squid merupakan perangkat lunak bebas.

Interface Pada Mikrotik

MikroTik RouterOS mensupport bebagai macam tipe Ethernet Interfaces
–          Interface EOIP Tunnel : Ethernet over IP (EoIP) Tunneling MikroTik RouterOS adalah protokol yang membuat sebuah Ethernet tunnel antara dua router di atas koneksi IP. Interface EoIP muncul sebagai interface Ethernet. Ketika fungsi bridging dari router diaktifkan, semua lalu lintas Ethernet (semua protokol Ethernet) akan dijembatani sama seperti jika ada dimana interface Ethernet fisik dan kabel antara dua router (dengan bridging diaktifkan).
–          Interface IP Tunnel : IPIP tunnel is adalah sebuah protokol sederhana yang mengenkapsulasi paket IP dalam IP untuk membuat tunnel di antara dua router. IPIP tunnel interface muncul sebagai interface dalam daftar interface. Banyak router, termasuk Cisco dan berbasis Linux, mendukung protokol ini.
–          Interface VLAN : adalah sebuah cara pengelompokan satu set port switch bersama sehingga mereka membentuk logical network, terpisah dari kelompok seperti lainnya. Dalam sebuah switch tunggal ini adalah straightforward local configuration. Ketika VLAN meluas lebih dari satu switch, link antar-switch harus menjadi trunks, di mana paket ditandai untuk menunjukkan yang mereka milik VLAN.
–          Interface VRRP : Virtual Router Redundancy Protocol adalah sebuah protokol pemilihan yang menyediakan availabelity tinggi untuk router. Sejumlah router dapat berpartisipasi dalam satu atau lebih router virtual. Satu atau lebih alamat IP mungkin ditugaskan ke router virtual. Sebuah node router virtual dapat berupa salah satu dari status berikut:
• MASTER state
• BACKUP state
–          Interface Bonding : Bonding adalah teknologi yang memungkinkan multiple ethernet-like interfaces menjadi satu virtual link, sehingga mendapatkan data rates yang lebih tinggi dan menyediakan failover.
Property Description :
name ( name ; default: etherN ) – dimana ‘N’ adalah jumlah Ethernet interface
arp ( disabled | enabled | proxy-arp | reply-only ; default: enabled ) – Address Resolution Protocol
cable-setting ( default | short | standard ; default: default ) – perubahan pengaturan length kabel (hanya berlaku untuk NS DP83815/6 cards)
• default – suport long cables
• short – support short cables
• standard – same as default
mtu ( integer ; default: 1500 ) – Maximum Transmission Unit
disable-running-check ( yes | no ; default: yes ) – disable running check. Jika bernilai ‘no’, route secara otomatis mendeteksi kapanpun NIC terhubung ke device di the network atau tidak
mac-address ( MAC address ) – mengatur Media Access Control number of the card
auto-negotiation ( yes | no ; default: yes ) – jika memungkinkan, interface “advertises” nya secara maksimum kemampuan untuk mencapai koneksi terbaik
full-duplex ( yes | no ; default: yes ) – mendefinisikan apakah transmisi data muncul dalam dua
arah secara simultan speed ( 10 Mbps | 100 Mbps | 1 Gbps ) – menentukan kecepatan transmisi data interface. Oleh
default, nilai ini adalah maksimal data rate yang didukung oleh antarmuka

Setting ubuntu sebagai gateway internet

setting ubuntu sebagai gateway :
================================
contoh :
Ip ubuntu ke modem (eth0) : 192.168.1.253/24
Gateway (ip modem) : 192.168.1.1
IP ubuntu ke lan (eth1):192.168.45.1/24

Langkah utama ada 4 yaitu :

=================================
1. Seting IP di eth0 dan eth1
=================================
pico /etc/network/interfaces
=================================
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
address 192.168.1.253
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
gateway 192.168.1.1
# dns-* options are implemented by the resolvconf package, if installed
dns-nameservers 8.8.8.8 8.8.4.4
auto eth1
iface eth1 inet static
address 192.168.45.1
netmask 255.255.255.0
=================================
simpan konfigurasi dan keluar, lalu restart menggunakan perintah :
/etc/init.d/networking restart

=================================
=================================
2. seting IP Forwarding
=================================
pico /etc/rc.local
tambahkan rules berikut sebelum exit 0 :
echo 1 > /proc/sys/net/ipv4/ip_forward

lalu simpan perubahannya.

=================================
pico /etc/sysctl.conf
=================================
# Uncomment the next line to enable packet forwarding for IPv4
net.ipv4.ip_forward=1

ketikkan perintah :
sysctl -p

apabila reportnya :
net.ipv4.ip_forward=1

berarti ip forwarding sudah aktif.

=================================
=================================
3. Membuat iptables
=================================
pico /etc/rc.local

sesudah rule :
echo 1 > /proc/sys/net/ipv4/ip_forward

tambahkan rule berikut :
iptables –t nat –A POSTROUTING –j MASQUERADE

jika menggunakan squid/lusca sebagai proxy, tambahkan rule berikut (sesuaikan dengan konfigurasi port dalam squid.conf :
iptables –t nat –A PREROUTING –p tcp –dport 80 –j REDIRECT –to-port 3128

jika proxy yang digunakan mendukung ssl bump untuk cache https, tambahkan rule berikut (sesuaikan dengan konfigurasi port dalam squid.conf :
iptables –t nat –A PREROUTING –p tcp –dport 443 –j REDIRECT –to-port 3127

lalu simpan perubahannya.
aktifkan rc.local dengan mengetikkan perintah :
/etc/init.d/rc.local start

=================================
=================================
4. Testing di client
=================================
Setting IP di salah satu client dengan konfigurasi berikut :
ip : 192.168.45.2
netmask : 255.255.255.0
gateway : 192.168.45.1
DNS : 8.8.8.8 8.8.4.4

tes ping pada cmd
ping 8.8.8.8

Jika reply saat ping, maka seting gateway sudah ok.
Jika belum? tanya forum atau teman yang lebih tahu 🙂

mungkin dapat di implementasikan pada router mikrotik sebagai client dari gateway ubuntu server

PENGERTIAN SERTA JENIS-JENIS FILE SYSTEM LINUX DAN WINDOWS

PENGERTIAN SERTA JENIS-JENIS FILE SYSTEM LINUX DAN WINDOWS

Bagi yang ingin tahu tentang pengertian dan jenis-jenis file system yang terdapat pada linux dan windows mudah-mudahan akan dapat membantu.

  1. A.      PENGERTIAN

File System/sistem berkas adalah struktur logika yang digunakan untuk mengendalikan akses terhadap data yang ada pada harddisk. Dalam File System, terdapat berbagai jenis-jenisnya dan penggunaan algoritma yang berbeda. Semakin baru jenis dari sebuah File System, maka semakin bagus pula kualitas dari File System tersebut. Misalnya FAT (File Allocation Table). Jenis partisi terdahulu pada Windows yang kemudian diperbaharui dengan adanya FAT-16, FAT -32, dan yang terakhir adalah jenis NTFS (New Technology File System). Pada Linux, terdapat jenis File System EXT 2 (Extended 2), Swap (Virtual Memory), dan lain-lain. File System terbaru pada Linux adalah EXT 4 yang tentunya lebih baik dari versi-versi EXT yang lainnya.

File System pada Linux itu lebih powerfull ketimbang File System pada Windows. Karena struktur logika yang digunakan pada Windows seperti FAT dan NTFS memiliki kekurangan seperti mudah diserang oleh para Cracker, mudah terinfeksi virus, harus di defrag beberapa waktu, dan lain-lain. Pada Linux juga memiliki kekurangan. Tapi kekurangan tersebut tidak berarti. Seperti pengaturan partisi dan pengelolaannya yang kurang user-friendly bagi anda yang tidak terbiasa. Kelebihan File System di Linux sepertinya melebihi File System di Windows. Seperti keamanan yang lebih bagus dan susah untuk terinfeksi virus.

  1. B.      JENIS-JENIS FILE SYSTEM

 

Berikut ini adalah beberapa jenis-jenis Disk file system yang sudah ada:

  1. FAT 16 adalah sebuah tipe file system yang dikenalkan kepada public pada jaman MSDOS. FAT 16 menggunakan cluster address 16 bit, hal ini yang mampu memberikan kemungkinan besar dari sebuah partisi mencapai ukuran hingga 2 GigaByte. Fat 16 menggunakan metode 8.3 (8.3 maksudnya adalah 8 nama file dan tiga extention) untuk melakukan suatu penamaan dari suatu file.
  2. FAT 32 adalah sebuah tipe file sistem pengembangan dari file sistem FAT 16, diperkenalkan ke masyarakat luas ketika era windows 98. FAT32 menggunakan cluster address 32 bit yang memungkinkan untuk membuat partisi hingga 124 GigaByte, akan tetapi bila kita melakukan format langsung dari windows, maka hanya terbatas hingga 32 GigaByte. Besar maximal file adalah 4 GigaByte (belum tentu cukup untuk kita menyimpan image dalam sebuah DVD).
  3. NTFS adalah file system yang digunakan pada windows berbasis NT (NT, 2000, XP, 2003, Vista). Pada file system ini besar partisi max 256 Terra Byte sedangkan besar datanya 16 Terra Byte. NTFS support terhadap metadata, yaitu database yang berisi informasi suatu file. Selain itu juga NTFS juga memiliki fasilitas seperti :
    1. quota = Pembatasan besar data untuk setiap user
    2. enkripsi = Fasilitas proteksi data dengan cara mengacak bit dalam suatu file sehingga tidak bisa terbaca oleh user yang tidak berhak
    3. kompresi = Fasilitas pemampatan data sehingga space akan lebih lapang

*Ingat :
Apabila anda menggunakan sistem operasi yang menggunakan partisi FAT maka file system NTFS tidak bisa di baca. Pada Linux file system bisa dibaca apabila fasilitas dari kernel diaktifkan, tetapi untuk menulis harus menggunakan program tambahan seperti ntfs-3g. Disarankan apabila menggunakan windows terbaru anda menggunakan NTFS sebagai file system nya.

  1. Ext2 (2rd Extented) adalah file system yang ampuh di linux. EXT2 juga merupakan salah satu file system yang paling ampuh dan menjadi dasar dari segala distribusi linux. Pada EXT2 file system, file data disimpan sebagai data blok. Data blok ini mempunyai panjang yang sama dan meskipun panjangnya bervariasi diantara EXT2 file sistem, besar blok tersebut ditentukan pada saat file sistem dibuat dengan perintah mk2fs. Jika besar blok adalah 1024 bytes, maka file dengan besar 1025 bytes akan memakai 2 blok. Ini berarti kita membuang setengah blok per file. EXT2 mendefinisikan topologi file system dengan memberikan arti bahwa setiap file pada sistem diasosiasiakan dengan struktur data inode. Sebuah inode menunjukkan blok mana dalam suatu file tentang hak akses setiap file, waktu modifikasi file, dan tipe file. Setiap file dalam EXT2 file system terdiri dari inode tunggal dan setiap inode mempunyai nomor identifikasi yang unik. Inode-inode file sistem disimpan dalam tabel inode. Direktori dalam EXT2 file sistem adalah file khusus yang mengandung pointer ke inode masing-masing isi direktori tersebut.
  2. Ext 3 (3rd Extended) adalah peningkatan dari EXT2 file sistem. Peningkatan ini memiliki beberapa keuntungan. Misalkan sebuah kasus seperti berikut :

Setelah kegagalan sumber daya (unclean shutdown) atau kerusakan sistem, EXT2 file sistem harus melalui proses pengecekan dengan program e2fsck. Proses ini dapat membuang waktu sehingga proses booting menjadi sangat lama, khususnya untuk disk besar yang mengandung banyak sekali data. Dalam proses ini, semua data tidak dapat diakses. Jurnal yang disediakan oleh EXT3 menyebabkan tidak perlu lagi dilakukan pengecekan data setelah kegagalan sistem. EXT3 hanya dicek bila ada kerusakan hardware seperti kerusakan hard disk, tetapi kejadian ini sangat jarang. Waktu yang diperlukan EXT3 file sistem setelah terjadi (unclean shutdown) tidak tergantung dari ukuran file sistem atau banyaknya file, tetapi tergantung dari besarnya jurnal yang digunakan untuk menjaga konsistensi. Besar jurnal default memerlukan waktu kira-kira sedetik untuk pulih, tergantung kecepatan hardware.

Dari kasus diatas bisa kita simpulkan bahwa keuntungan ext3, diantaranya:

  1. Integritas data. EXT3 menjamin adanya integritas data setelah terjadi kerusakan atau “unclean shutdown”. EXT3 memungkinkan kita memilih jenis dan tipe proteksi dari data.
  2. Kecepatan. Daripada menulis data lebih dari sekali, EXT3 mempunyai throughput yang lebih besar daripada EXT2 karena EXT3 memaksimalkan pergerakan head hard disk. Kita bisa memilih tiga jurnal mode untuk memaksimalkan kecepatan, tetapi integritas data tidak terjamin.
  3. Mudah dilakukan migrasi. Kita dapat berpindah dari EXT2 ke sistem EXT3 tanpa melakukan format ulang.

 

  1. Ext 4 (4rd Extended) dirilis secara komplit dan stabil berawal dari kernel 2.6.28 jadi apabila distro anda yang secara default memiliki versi kernel tersebuat atau di atas nya otomatis system anda sudah support ext4 (dengan catatan sudah di include kedalam kernelnya) selain itu versi e2fsprogs harus mengunakan versi 1.41.5 atau lebih. Apabila anda masih menggunakan fs ext3 dapat mengkonversi ke ext4 dengan beberapa langkah yang tidak terlalu rumit. Keuntungan yang bisa didapat dengan mengupgrade filesystem ke ext4 dibanding ext3 adalah mempunyai pengalamatan 48-bit block yang artinya dia akan mempunyai 1EB = 1,048,576 TB ukuran maksimum filesystem dengan 16 TB untuk maksimum file size nya, Fast fsck, Journal checksumming, Defragmentation support.
  2. Swap adalah File System yang tidak digunakan sebagai tempat penyimpanan data, tetapi sebagai virtual memory, yaitu sebagai pembantu kinerja dari si memory. Virtual memory ini juga digunakan pada windows dengan nama page file, tetapi kalau swap ditaruh pada partisi yang berbeda dengan system dan diberi tempat tersendiri, pada page file dia berada pada partisi yang sama dengan system atau data.
  3. Reiser File sistem. Reiser file sistem memiliki jurnal yang cepat. Ciri-cirinya mirip EXT3 file sistem. Reiser file sistem dibuat berdasarkan balance tree yang cepat. Balance tree unggul dalam hal kinerja, dengan algoritma yang lebih rumit tentunya. Reiser file sistem lebih efisien dalam pemenfaatan ruang disk. Jika kita menulis file 100 bytes, hanya ditempatkan dalam satu blok. File sistem lain menempatkannya dalam 100 blok. Reiser file sistem tidak memiliki pengalokasian yang tetap untuk inode. Resier file sistem dapat menghemat disk sampai dengan 6 persen.

How about Mac Address

networkingHari ini saya akan mencoba membahas tentang apa itu MAC Address. MAC address (Media Access Control Address) adalah  alamat jaringan pada lapisan layer 2 (data-link layer) dalam 7 osi layer. Dimana mac address ini sendiri merupakan sebuah alamat unik yang ada pada setiap perangkat jaringan (ethernet, wireless card, bluetooth, dll) yang memiliki alamat yang berbeda walaupun memiliki type dan jenis yang sama bahkan dibuat oleh vendor yang sama.

Mac address memiliki panjang alamat sebanyak 48 bit. Terdiri dari atas 12 digit bilangan heksadesimal (0 s/d F), 6 digit pertama mempresentasikan vendor pembuat kartu jaringan tersebut. Dan sisa nya id kartu jaringannya. Contoh alamat dari MAC address : 00-02-4C-4F-F0-50.

Mac address dengan sifat unik nya sering dimanfaatkan untuk keamanan jaringan. contoh implementasi nya adalah pada pengalamatan ip address yang menggunakan DHCP server sehingga kita bisa menstatik kan sebuah ip address pada sebuah perangkat/kartu jaringan.

Perbedaan Chain Mikrotik

Mungkin selama ini ada yang mencari perbedaan chain mikrotik. Maka kali ini saya akan mencoba membahas perbedaan antara chain input, output, foward, pre-routing, dan postrouting..

forward :
– Digunakan untuk proses paket data yang melewati router, koneksi yang terjadi dari public ke local
atau
– Koneksi yang terjadi dari local ke public
dengan ketentuan tanpa ada proses di dalam router, artinya koneksi tersebut adalah langsung dan hanya numpang lewat di router tidak ada terjadi suatu proses di dalam router.
input :
– Digunakan untuk memproses paket memasuki router melalui salah satu interface dengan alamat IP tujuan yang merupakan salah satu alamat router. Chain input berguna untuk membatasi akses konfigurasi terhadap Router Mikrotik.
atau
– Koneksi yang terjadi dari local menuju router dan berakhir di router
contoh : penggunaan proxy internal (proxy internal kan di dalem router tempatnya)
output :
– Digunakan untuk proses paket data yang berasal dari router dan meninggalkan melalui salah satu interface, koneksi yang terjadi dari router menuju public.
atau
– Koneksi yang terjadi dari router menuju local.
artinya koneksi tercipta karena router sendiri yang meminta (kebutuhan router itu, bukan dari local / public), contoh : hasil dari proxy internal mikrotik yang di kirimkan ke client.

prerouting :
Pre routing artinya koneksi yang akan masuk router (gak peduli dari mana/tergantung setting mangle in intercafe nya nanti)
koneksi ini akan di proses di dalam router, bisa proses pembelokan ke proxy external, bisa filtering port, bisa apa aja deh, pokoknya ada proses, nah prerouting itu menandai koneksi sebelum terjadi proses tersebut.

postrouting :
Postrouting adalah koneksi yang akan keluar router setelah terjadi proses di dalam router.

Perintah-perintah Dasar Mikrotik RouterOS

Bagi anda yang baru belajar menggunakan Mikrotik pasti masih bingung dengan perintah (command line) yang digunakan pada RouterOS. Padahal banyak perintah-perintah dasar Mikrotik yang penting dan wajib diketahui agar anda dapat menggunakan Mikrotik RouterOS dengan baik. Sebenarnya perintah–perintah dasar MikroTik RouterOS tidak jauh berbeda dengan perintah dasar pada linux umumnya. Karena sebetulnya mikrotik ini merupakan perkembangan dari kernel linux Debian.

 

Perintah shell Mikrotik RouterOS sama dengan linux, seperti penghematan perintah, cukup menggunakan tombol TAB di keyboard maka perintah yang panjang, tidak perlu lagi diketikkan, hanya ketikkan awal nama perintahnya, nanti secara otomatis Shell akan menampilkan sendiri perintah yang berkenaan. Misalnya perintah IP ADDRESS di mikrotik. Cukup hanya mengetikkan IP ADD spasi tekan tombol TAB, maka otomatis shell akan mengenali dan menterjemahkan sebagai perintah IP ADDRESS.

 

Berikut ini merupakan perintah perintah dasar Mikrotik yang umum digunakan :

1. Perintah untuk shutdown dan restart computer , ketikkan :
[admin@MikroTik]>system shutdown  (Untuk shutdown komputer )
[admin@MikroTik]>system reboot       (Untuk restart computer )
[admin@MikroTik]>system reset   (Untuk meret konfigurasi yang sudah dibuat sebelumnya). Dan perlu diperhatikan bahwa perintah – perintah tersebut harus dilakukan pada direktori admin.
2. Perintah untuk merubah nama mesin Mikrotik , ketikkan :
[admin@MikroTik]>/system identity
[admin@MikroTik]>system identity > set name=proxy
Untuk melihat hasil konfigurasi , ketikkan “print” atau  “pr”
Contok [admin@MikroTik]system indentity>pr name:”proxy”
Lalu console berubah menjadi [admin@proxy]
3. Perintah merubah password mesin MikroTik , ketikkan
[admin@proxy]>/ password
[admin@proxy]password>old password (jika sebelumnya anda belum mengeset password maka ketikkan kosong)
[admin@proxy]password>new password :……(ketikkan password yang baru)
[admin@proxy]password>retype new password: ……..(masukkan sekali lagi passowrdnya)
Sebagai contoh :
Jika  password lama kosong dan password baru ABCD, maka perintahnya adalah sebagai berikut :
[admin@proxy]>/password
[admin@proxy]password>old password
[admin@proxy]password>new password ABCD
[admin@proxy]password>retype new password ABCD
4. Perintah untuk melihat kondisi interface pada Mikrotik Router :
[admin@Mikrotik] > interface print
Flags: X – disabled, D – dynamic, R – running
#    NAME                         TYPE             RX-RATE    TX-RATE    MTU
0  R ether1                        ether            0          0          1500
1  R ether2                       ether            0          0          1500
[admin@Mikrotik]>
Jika interfacenya ada tanda X (disabled) setelah nomor (0,1), maka periksa lagi
etherned cardnya, seharusnya R (running).
a. Mengganti nama interface
    [admin@Mikrotik] > interface(enter)
b. Untuk mengganti nama Interface ether1 menjadi Public (atau tersenamanya),maka:
    [admin@Mikrotik] interface> set 0 name=Public
c. Begitu juga untuk ether2, misalkan namanya diganti menjadi Local, maka
    [admin@Mikrotik] interface> set 1 name=Local
d. atau langsung saja dari posisi root direktori, memakai tanda “/”, tanpa tanda kutip
    [admin@Mikrotik] > /interface set 0 name=Public
e. Cek lagi apakah nama interface sudah diganti.
    [admin@Mikrotik] > /interface print
    Flags: X – disabled, D – dynamic, R – running
#    NAME                         TYPE             RX-RATE    TX-RATE    MTU
0  R Local                        ether            0          0          1500
1  R Public                       ether            0          0          1500
5. Perintah untuk melihat paket sofwtware MikroTik OS :
[admin@proxy]>/system package
[admin@proxy]system package><ketikkan print atau pr>
Dengan perintah diatas maka akan tampil paket softwore yang ada dalam MikroTik Os Contoh :
[admin@MikroTik  system package> pr
Flags : x – disabled
 #       Name
0   X routing – test
1   dhcp
2   radiolan
3   user-menejer
4   X webproxy-test
5   arlan
6   isdn
7   hotspot-fix
8   ppp
9   wireless
10  web-proxy
11  hotspot
12  advanced-tools
13  security
14  Telephony
15  routing
16  synchronous
17  system
18  routerboard
19  rstp-bridge-test
20  X wireless-legecy
VERSION
2.9.27
2.9.27
2.9.27
2.9.27
2.9.27
2.9.27
2.9.27
2.9.27
2.9.27
2.9.27
2.9.27
2.9.27
2.9.27
2.9.27
2.9.27
2.9.27
2.9.27
2.9.27
2.9.27
2.9.27
2.9.27
SCHEDULED
     Untuk  melihat lebih detailnya, ketikan :
     [admin@proxy]system package > pr detail fl           gs : x – disabled
0         x name=”routing-test” version=”2.9.27” build – time =jul/03/2006 10:57:53 scheduled
1         name =”system”version =”2.9.27” build – time=jul/03/2006 10 :56:37 schedule
2         name =”system”version =”2.9.27” build – time=jul/03/2006 10 :56: 44  schedule
3         name=”web-proxy” version=”2.9.27” build-time=jul/03/2006 10:`58 :03 schedule
4         name=”advanced –tools” version=”2.9.27” build –time=jul /03/2006 10:56 : 41 scheduled=””
5         name=”dhcp” version=”2.9.27” build-time=jul/03/2006 10:56:45 scheduled=””
6         name =”hotspot”version=”2.9.27”build-time=jul/03/2006 10:56:58 scheduled=””
7         x name=”webproxy-test” version=”2.9.27” build-time=jul / 03 /2006 10:57:52 scheduled
8         name=”routerboard” version =”2.9.27” build-time=jul / 03 / 2006 10: 57 : 17 –[q quit‌  ׀ D dump ׀ up ׀ down ]
6. Perintah untuk mengupgrade paket software router :
[admin@Mikrotik] system upgade>
To upgrade chosen packages :
Download 0,1,2,3,4,5,6,7,8,9,10,11,12,13,14
7. Perintah mengaktifkan paket software yang ada dalam MikroTik OS :
    [admin@Mikrotik]system page>
     Enable <ketikkan paket yang dikehendaki>
Contoh :
[admin@proxy] system package> enable dhcp
8. Perintah merubah nama ethernet pada mesin MikroTik OS:
[admin@proxy]>/interface
[admin@proxy]interface>ethernet set etherl nama=public
Atau dengan menggunakan perintah
[admin@proxy]interface>set<ketikan number ethernet yang terpasang>
 name=<nama ethernet   yang baru >
contoh :
[admin@proxy]interface> set 0 name=public
[admin@proxy]interface>set 1 name=lan
Atau
[admin@proxy]interface>
set 0 name=public; set 1 name=lan
9Perintah setting IP address pada mesin MikroTik OS :
[admin@proxy]> ip address
[admin@proxy]ip address>
Add interface=<nama interface>anddress=
(ketikkan IP address/subnet mask interface)
Contoh :
Jika nama interfacenya “lan” dan IP address yang dikehendaki : 192.168.01 dan subnet mask : 255.255.255.0, maka perintahnya  sebagai berikut
[admin@proxy]>/ ip address
[admin@proxy]ip address >
Add interface=lan address = 192.168.0.1/24
10. Perintah setting IP DNS primaty dan Secondary :
[admin@proxy]./ip dns
[admin@proxy]ip dns>
Set nama-dns>=<Ip dns dari ISP>
Contoh :
Jika IP DNS primary ISP : 202.134.1.10 dan secondary:
202.134.0.0155, maka perintahnya adalah sebagai berikut :
[admin@proxy]./ip dns
[admin@proxy]ip dns>
Set primary-dns= 202.134.1.10
[admin@proxy]ip dns>
Set secondary-dns=202.134.0.155
11. Perintah setting IP Gateway pada mesin MikroTik OS
[admin@proxy]>/ip route
[admin@proxy]ip route >add gateway=<ip gatway
Contoh IP gateway  dari ISP : 202.134.1.1, maka perintahnya :
[admin@proxy]>/ ip route
[admin@proxy] ip route>
add  gateway=202.134.1.1
12. Perintah Network address Translate (NAT) pada mesin MikroTik OS
[admin@proxy]>/ip firewall nat
[admin@proxy]ip firewall nat>
add  chain=srcnat out-interface=<etherface yang terhubung
dengan jaringan WAN> scr-address=
<network-id interface yang terhubung dengan LAN / subnet mask interface
LAN> action=masqurade
Contoh :
jika network-id interface LAN :”192.168.0.0” dan subnet
Mask :”255.255.255.0”. untuk interface mesin MikroTik OS yang terhubung ke jaringan
WAN : “pubilk”, maka perintahnya sebagai berikut :
[admin@proxy] >/ip firewall nat
[admin@proxy[ ip firewall nat>
Add chain=srcnat out-interface=public
Scr-address=192.168.0.0/24 action=masquerade

Perintah-perintah Dasar Cisco

Perintah-perintah Dasar Cisco

Beberapa perintah umum atau dasar yang sering digunakan ketika kita berhadapan dengan router cisco untuk beberapa kasus jika anda ingin menampilkan bantuan dengan menambahkan tanda tanya (?) di console maka akan muncul beberapa perintah yang dapat anda gunakan.

Keyboard Shortcuts

  • CTRL-N  menunjukkan perintah selanjutnya.
  • CTRL-P   menunjukkan perintah sebelumnya.
  • CTRL-Z keluar dari config terminal ke mode privilage.
  • CTRL-C untuk melakukan cancel.
  • SHIFT-CTRL-6  Break.
  • Tab melengkapi perintah anda.
  • Q untuk keluar.
  • Konfigurasi Router

Anda akan dapat mempelajari perintah-perintah dasar untuk mengkonfigurasi router.

  • sh running-config  – rincian file konfigurasi berjalan (RAM)
  • sh startup-config – menampilkan konfigurasi yang tersimpan di NVRAM
  • Setup – Apakah memulai setup otomatis; sama seperti ketika Anda boot pertama penerus
  • config t – gunakan untuk menjalankan perintah konfigurasi dari terminal
  • config mem – mengeksekusi perintah konfigurasi yang tersimpan dalam NVRAM; copy
  • startup-config untuk menjalankan-config
  • config net – digunakan untuk mengambil informasi konfigurasi dari server TFTP
  • copy running-config startup-config   salinan disimpan dalam menjalankan config (RAM) ke NVRAM (melakukan penyimpanan terhadap konfigurasi berjalan).
  • copy startup-config running-config- salinan dari non-volatile (NVRAM) untuk konfigurasi yang sedang berjalan (RAM)
  • boot system flash – yang memberitahu router IOS file untuk boot dari dalam flash
  • boot system tftp – yang memberitahu router IOS file pada server untuk boot dari tftp
  • boot system rom – kirim router untuk boot dari ROM di boot berikutnya
  • copy flash tftp – Salin flash ke tftp server
  • copy tftp flash – Mengembalikan flash dari server tftp
  • copy run tftp – Salinan arus config yang sedang berjalan untuk server tftp
  • copy tftp run – Mengembalikan config yang sedang berjalan dari server tftp

Perintah Umum
Berikut adalah daftar perintah umum. Ini adalah perintah tingkat dasar dan paling umum digunakan

  • no shutdown – (Mengaktifkan interface)
  • reload – Merestart Router
  • sh ver – Cisco IOS versi, uptime dari penerus, bagaimana router dimulai, dimana sistem ini diambil dari, interface POST ditemukan, dan konfigurasi register
  • sh clock – Menampilkan jam dan tanggal pada router
  • sh history – Mendampilkan daftar perintah yang telah anda berikan
  • sh debug – menunjukkan semua debug yang sedang diaktifkan
  • no debug all – Mematikan seluruh debug
  • sh users – Menampilkan Pengguna yang terhubung ke Router
  • sh protocols – menunjukkan yang telah dikonfigurasi dengan protokol
  • banner motd # pesan khusus Anda di sini # – SSet/change banner
  • hostname – untuk mengkonfigurasi nama host dari router
  • clear counters – counter antarmuka yang jelas

Keistimewaan (Privilege) Mode perintah router
Belajar bagaimana bekerja dalam modus istimewa dari sebuah router.

  • enable – Mengaktifkan mode privilege
  • disable – Menonaktifkan mode privilege
  • enable password – Mensetting pasword pada mode privilege
  • enable secret – set password terenkripsi modus istimewa

Pengaturan Sandi di router
Di sini Anda akan dapat belajar bagaimana untuk mengatur password pada router.

  • enable secret – mengatur sandi terenkripsi untuk akses istimewa
  • enable password – set password untuk akses istimewa (yang digunakan ketika tidak ada rahasia mengaktifkan dan bila menggunakan software yang lebih lama)

Menetapkan password untuk akses konsol:

  • (config)#line console 0
  • (config-line)#password
  • (config-line)#login

Set password for virtual terminal (telnet) access

  • (config)#line vty 0 4
  • (config-line)#password
  • (config-line)#login

Set password for auxiliary (modem) access:

  • (config)#line aux 0
  • (config-line)#password
  • (config-line)#login

Proses Router & Statistik
Dengan perintah ini Anda dapat melihat statistik dan proses yang berbeda dari router.

  • sh processes – Menampilkan proses yang aktif pada router
  • sh process cpu – Menampilkan statistik CPU
  • sh mem – Menampilkan statistik Memory
  • sh flash – menggambarkan memori flash dan menampilkan ukuran file dan jumlah memori flash bebas
  • sh buffers – menampilkan statistik untuk daerah penyangga router; menunjukkan ukuran Kecil, Menengah, Besar, Sangat Besar, Buffer Besar dan besar
  • sh stacks – menunjukkan alasan untuk reboot terakhir, monitor tumpukan menggunakan proses dan rutin interupsi

Perintah IP

  1. show ip route – melihat tabel ip routing
  2. show ip address brief melihat ip address list.
  3. ip route [administrative_distance] – konfigurasi  IP statik Router
  4. ip route 0.0.0.0 0.0.0.0 [next hops] – Mensttinf gateway dasar
  5. ip classless – digunakan dengan static routing agar paket-paket yang ditujukan untuk subnet yang belum diakui untuk menggunakan rute terbaik
  6. sh arp – melihat arp cache; menunjukkan alamat MAC dari router yang terhubung
  7. ip address x.x.x.x y.y.y.y  untuk menambah ip address format x.x.x.x ( ip address) y.y.y.y (subnetmask).

Perintah CDP (Cisco Discovery Protocol menggunakan lapisan 2 multicast melalui link SNAP-mampu mengirim data):

  • sh cdp neighbor – menunjukkan langsung terhubung jaringan tetangga
  • sh cdp int – menunjukkan yang menjalankan interface CDP
  • sh cdp int eth 0/0 – menampilkan info CDP untuk interface tertentu
  • sh cdp entry – menunjukkan detail CDP jaringan lainnya
  • cdp timer 120 – mengubah cara sering info CDP dikirim (cdp timer default adalah 60)
  • cp holdtime 240 – berapa lama untuk menunggu sebelum mengeluarkan CDP jaringan lainnya (CDP holdtime default adalah 180)
  • sh cdp run – menunjukkan CDP di aktifkan
  • no cdp run – mematikan CDP untuk seluruh router (config global)
  • no cdp enable – mematikan CDP pada interface tertentu

Sumber : http://bangmaman.web.id

Protokol Osi Layer dan TCP/IP

Apakah itu protokol OSI Layer dan TCP/IP Layer

1. Pengertian Protokol

Sebelum membahas lebih jauh tentang pengertian dari masing-masing layer dalam protokol, alangkah baiknya kita mengetahui terlebih dahulu apa itu protokol dalam sebuah Jaringan Komputer ? .

Protokol adalah sebuah aturan atau standar yang mengatur atau mengijinkan terjadinya hubungan, komunikasi, dan perpindahan data antara dua atau lebih titik komputer.

Protokol dapat diterapkan pada perangkat keras, perangkat lunak atau kombinasi dari keduanya. Pada tingkatan yang terendah, protokol mendefinisikan koneksi perangkat keras.

Prinsip dalam membuat protokol ada tiga hal yang harus dipertimbangkan, yaitu efektivitas, kehandalan, dan Kemampuan dalam kondisi gagal di network. Protokol distandarisasi oleh beberapa organisasi yaitu IETF, ETSI, ITU, dan ANSI.

Tugas yang biasanya dilakukan oleh sebuah protokol dalam sebuah jaringan diantaranya adalah :

  • Melakukan deteksi adanya koneksi fisik atau ada tidaknya komputer / mesin lainnya.
  • Melakukan metode “jabat-tangan” (handshaking).
  • Negosiasi berbagai macam karakteristik hubungan.
  • Bagaimana mengawali dan mengakhiri suatu pesan.
  • Bagaimana format pesan yang digunakan.
  • Yang harus dilakukan saat terjadi kerusakan pesan atau pesan yang tidak sempurna.
  • Mendeteksi rugi-rugi pada hubungan jaringan dan langkah-langkah yang dilakukan selanjutnya.
  • Mengakhiri suatu koneksi.

2. Pengertian Model Osi Layer

Pengertian model OSI (Open System Interconnection) adalah suatu model konseptual yang terdiri atas tujuh layer, yang masing-masing layer tersebut mempunyai fungsi yang berbeda.

OSI dikembangkan oleh badan Internasional yaitu ISO (International Organization for Standardization) pada tahun 1977.

Model ini juga dikenal dengan model tujuh lapis OSI (OSI seven layer model). Berikut dibawah ini merupakan gambar dari model OSI 7 Layer

Definisi masing-masing Layer pada model OSI

7. Application adalah Layer paling tinggi dari model OSI,  seluruh layer dibawahnya bekerja untuk layer ini, tugas dari application layer adalah Berfungsi sebagai antarmuka dengan aplikasi dengan fungsionalitas jaringan.

Mengatur bagaimana aplikasi dapat mengakses jaringan, dan kemudian membuat pesan-pesan kesalahan. Protokol yang berada dalam lapisan ini adalah HTTP, FTP, SMTP, NFS.

6. Presentation berfungsi untuk mentranslasikan data yang hendak ditransmisikan oleh aplikasi ke dalam format yang dapat ditransmisikan melalui jaringan.

Protokol yang berada dalam level ini adalah perangkat lunak redirektor (redirector software), seperti layananWorkstation (dalam windows NT) dan juga Network shell (semacam Virtual network komputing (VNC) atau Remote Dekstop Protokol (RDP).

5. Session Berfungsi untuk mendefinisikan bagaimana koneksi dapat dibuat, dipelihara, atau dihancurkan. Selain itu, di level ini juga dilakukan resolusi nama.

4. Transport Berfungsi untuk memecah data ke dalam paket-paket data serta memberikan nomor urut ke paket-paket tersebut sehingga dapat disusun kembali pada sisi tujuan setelah diterima.

Selain itu, pada level ini juga membuat sebuah tanda bahwa paket diterima dengan sukses (acknowledgement), dan mentransmisikan ulang terhadap paket-paket yang hilang di tengah jalan.

3. Network Berfungsi untuk mendefinisikan alamat-alamat IP, membuat header untuk paket-paket, dan kemudian melakukan routing melalui internetworking dengan menggunakan router dan switch layer3.

2. Data Link Befungsi untuk menentukan bagaimana bit-bit data dikelompokkan menjadi format yang disebut sebagai frame. Selain itu, pada level ini terjadi koreksi kesalahan, flow control, pengalamatan perangkat keras seperti halnya Media Access Control Address (MAC Address), dan menetukan bagaimana perangkat-perangkat jaringan seperti hub, bridge, repeater, dan switch layer2 beroperasi.

Spesifikasi IEEE 802, membagi level ini menjadi dua level anak, yaitu lapisan Logical Link Control (LLC) dan lapisan Media Access Control (MAC).

1. Physical adalah Layer paling bawah dalam model OSI, berfungsi untuk mendefinisikan media transmisi jaringan, metode pensinyalan, sinkronisasi bit, arsitektur jaringan (seperti halnya Ethernet atau Token Ring), topologi jaringan dan pengabelan.

Selain itu, level ini juga mendefinisikan bagaimana Network Interface Card (NIC) dapat berinteraksi dengan media kabel atau radio.

3. Cara Kerja Model OSI

Cara Kerja : Pembentukan paket dimulai dari layer teratas model OSI.

Aplication layer megirimkan data ke presentation layer, di presentation layer data ditambahkan header dan atau tailer kemudian dikirim ke layer dibawahnya, pada layer dibawahnya pun demikian, data ditambahkan header dan atau tailer kemudian dikirimkan ke layer dibawahnya lagi, terus demikian sampai ke physical layer.

Di physical layer data dikirimkan melalui media transmisi ke host tujuan.

Di host tujuan paket data mengalir dengan arah sebaliknya, dari layer paling bawah kelayer paling atas.

Protokol pada physical layer di host tujuan mengambil paket data dari media transmisi kemudian mengirimkannya ke data link layer, data link layer memeriksa data-link layer header yang ditambahkan host pengirim pada paket,  jika host bukan yang dituju oleh paket tersebut maka paket itu akan di buang, tetapi jika host adalah yang dituju oleh paket tersebut maka paket akan dikirimkan ke network layer, proses ini terus berlanjut sampai ke application layer di host tujuan.

Proses pengiriman paket dari layer ke layer ini disebut dengan “peer-layer communication”.

3. Pengertian TCP/IP

TCP/IP (Transmission Control Protokol / Internet Protokol ) adalah standar komunikasi data yang digunakan oleh komunitas internet dalam proses tukar-menukar data dari satu komputer ke komputer lain di dalam jaringan Internet.

Protokol TCP/IP dikembangkan pada akhir dekade 1970-an hingga awal 1980-an sebagai sebuah protokol standar untuk menghubungkan komputer-komputer dan jaringan untuk membentuk sebuah jaringan yang luas (WAN).

TCP/IP merupakan sebuah standar jaringan terbuka yang bersifat independen terhadap mekanisme transport jaringan fisik yang digunakan, sehingga dapat digunakan di mana saja.

4. Definisi Masing-masing Layer pada model TCP/IP

4Application merupakan Layer paling atas pada model TCP/IP, yang bertanggung jawab untuk menyediakan akses kepada aplikasi terhadap layanan jaringan TCP/IP.

Protokol ini mencakup protokol Dynamic Host Configuration Protocol (DHCP), Domain Name System (DNS), Hypertext Transfer Protocol (HTTP), File Transfer Protocol (FTP), Telnet, Simple Mail Transfer Protocol (SMTP), Simple Network Management Protocol (SNMP), dan masih banyak protokol lainnya.

Dalam beberapa implementasi Stack Protocol, seperti halnya Microsoft TCP/IP, protokol-protokol lapisan aplikasi berinteraksi dengan menggunakan antarmuka Windows Sockets (Winsock) atau NetBios over TCP/IP (NetBT).

3. Transport berguna untuk membuat komunikasi menggunakan sesi koneksi yang bersifat connection-orientedatau broadcast yang bersifat connectionless.

Protokol dalam lapisan ini adalah Transmission Control Protocol (TCP) dan User Diagram Protocol (UDP).

2. Internet berfungsi untuk melakukan pemetaan (routing) dan enkapsulasi paket-paket data jaringan menjadi paket-paket IP.

Protokol yang bekerja dalam lapisan ini adalah Internet Protocol (IP), Address Resolution Protocol (ARP),Internet control Message Protocol (ICMP), dan Internet Group Management Protocol (IGMP).

1. Network Interface berfungsi untuk meletakkan frame – frame jaringan di atas media jaringan yang digunakan.

TCP/IP dapat bekerja dengan banyak teknologi transport, mulai dari teknologi transport dalam LAN (seperti halnya Ethernet dan Token Ring), Man dan Wan (seperti halnya dial-up model yang berjalan di atas Public Switched Telephone Network (PSTN), Integrated Services Digital Network (ISDN), serta Asynchronous Transfer Mode (ATM).

Load more

Translate »